Skip to main content

Search

Versioning - Versioning

Comments

12 comments

  • Ardevia Forum

    Original Post by dany (Imported from Ardevia Forum)

    Just tried out again. Versioning does work even if configured after a form has previously been customized.
    Posts on the web seem to suggest the "HRESULT: 0x80131904" error is connected to SharePoint's SQL database (i.e. database full):

    Exception from HRESULT: 0x80131904 when i creating new item

     

    http://www.infragistics....nity/forums/t/73346.aspx

     

    Does the form work again when you remove the versioning?

    0
  • Ronald Laan

    I got the exact same issue. After disabling versioning the customized edit form works. This however is not a solution. It seems Rich Forms cannot handle versioning in custom list, which to me looks like a bug.

    0
  • Rosario Matos

    HiRonald Laan

    After discussing via Skype with Ramses Kooijman, follows the answer to all community.

    The problem was in bad request wich was send with bad payload info.
    If we delete default toolbar on edit form and enabled versioning on list, then bad request will be send and we will get an error.
    So we must had toolbar on edit form then proper request will be sent.
    How to reproduce issue:
    1. Customize edit form
    2. Remove toolbar
    3. Create button save action
    4. Enable versioning on list

    I hope it helps some of you.

    Regards

    Rosario Matos

    0
  • Jelle Dijkstra

    Hi Rosaria/ All,

     

    I have the same issue with an customized editForm.
    On the List the versioning option is enabled.
    When versioning is enabled than I got the HResult error and I am not able to save the edited List Item .

    If I turn off the versioning the EditForm will save successfully.

     

     

    When I remove customizing the editForm works well.

     

    The editForm is an import(copy) of the newForm. The newForm works well.

     

    So it must be something with the customized editForm and versioning which causes this.

     

     

     

    Does someone has a solution how to get rid of this error. One of the requirements is versioning so I am looking forward for a resolution.

     

    regards,
    Jelle Dijkstra

    0
  • Adis Jugo

    Hi Jelle Dijkstra 

     

    The issue is in SharePoint's handling requests in the edit forms, especially when imported from the new form. As described above by Rosario, you will need to recreate the save functionality.

     

    1. Edit the form

    2. Remove the block with save and cancel buttons (we call it "Toolbar")

    3. save form

     

    Then try reading the toolbar again from the ribbon menu:

     

     

    If the error by chance reappears (what it could, depending on the payload), please delete the "toolbar" with save and cancel buttons again, and add those two buttons manually from the "Button and Link" option.

     

     

    Please let me know if this does [not] work.

     

    Cheers, Adis

    0
  • Jelle Dijkstra

    Hi Adis,

     

    Thanks for your reply.

    I tried your suggestion and it works.

     

    Thanks a lot.

     

    Kind regards,

    Jelle Dijkstra

    0
  • Tadej Cajner

    Hi Adis

    I have the same issue with a customized editForm, imported from newForm. But even if I don't use newForm (if I create item in Datasheet view), the problem is the same: when I open it in editForm and I click Save it generates "HRESULT: 0x80131904" (the sime thing with default toolbar, skybow toolbar or manually created button).

    This happens only when the versioning option is enabled. If I turn off versioning everything works fine. Versioning is the requirement.

    I tried your solution step by step with no success.

    Is ther something else I could try?

     

    Regards,

    Tadej

    0
  • Christof Nussbaumer

    Hi Tadej Cajner
    If you're facing this HRESULT: 0x80131904 error without using a customized form it's most likely a SQL Server Problem mentioned above (no free space left, or something like that): https://www.google.com/search?q=HRESULT%3A+0x80131904 

    0
  • Tadej Cajner

    Hi Christof,

     

    without customized form I don't receive error.

     

    Tadej

    0
  • Christof Nussbaumer

    Hi Tadej Cajner
    Can you please reply to the mail sent by skybow support with your availability for a session?

    0
  • Tadej Cajner

    Hello Christof,

     

    I think that is important that site colection admin and server admin are present in a session, so I will try to arrange that they will be here on thursday 16th January from 9:00 to 12:00. I will confirm this ASAP with exact time. Is this timing acceptable for you?

     

    Best regards,

     

    Tadej

    0
  • Christof Nussbaumer

    Hi Tadej Cajner
    On Thursday 16th January I have a free slot from 09:00 - 10:00 UTC+1. But please let's continue this kind of communication in the support ticket we sent you by email.

    0

Please sign in to leave a comment.