Skip to main content

Search

Backups

Comments

8 comments

  • Ardevia Forum

    Original Post by iryna (Imported from Ardevia Forum)

    The customized part of a form is a usual Content Editor web part. The simplest way to backup a form is to save the source code of the page (Edit Source button on the Format Text ribbon tab).
    The only problem in this case is that IDs of subists/related lists and web parts are unique and should be changed in the code manually. Or subists/related lists and web parts can be deleted and added again.

     

    To backup your customization:
    1. save your lists (and all sublists, related lists) as templates (http://www.fpweb.net/sharepoint-2013/tutorials/content/create-list-template#)
    2. save the source code of your customized forms.

     

    You can also save a site template. In this case, the customized source code is saved and you just need to change the IDs.

     

    If you need more assistant please provide more information or contact us.

    0
  • Ardevia Forum

    Original Post by maryb (Imported from Ardevia Forum)

    Thank you Pavlyukh.

     

    I am having difficulty with the back up and restore of customised list with sub-list.

     

    The problem:  After importing my two lists I have to re-insert sub-list to customised list
                  In the sub-list there is a lookup column referencing my main list.
                  The sub list is inserted but the content doesn't flow over ie: when I view/edit list    items that were previously documented.

     

    Perhaps I am missing a step.

     

    Also when I try to save site as a template I encounter the following error:
    Sorry, something went wrong
    Sorry, this site can't be saved as a template. It contains apps that don't work in templates:
    Ardevia Rich Forms Pro

     


    Many thanks & grateful for your help.

    0
  • Ardevia Forum

    Original Post by iryna (Imported from Ardevia Forum)

    Will try do describe steps to restore form with configured sublist more precisely:

     

    1. In the sublist check the lookup column to the parent list. If it is broken ("Get information from:" - empty), delete it and create one more with the same name.
    2. Open form in design mode
    3. Insert the sublist
    4. Using developer tools(F12) find the following Ids:
    Code:

    ard-webpart-id="b3c1641f-790d-4f22-b469-dc24880aeae2"
    ard-sublist-lookup-listid="{7c6a5e0c-e3f5-45f7-9915-7efe034f753b}"
    ard-sublist-lookup-webid="{6fd54f15-115e-4a4f-8ce6-c68a0876a50d}"
    


    NhaBKBVKuT8RGTqXZDWvzkV8xuPC4E.png

     

     

    5. Select the sublist and click Delete button from the Rich Forms tab of the ribbon. But when alert with the question "Are you sure you want to remove ... web part from the page completely?", click "Cancel"
    6. Change the source code of the page with the source code of the previously configured page.
    7. Replace the Ids with the saved ones (from Step 4)
    8. Save changes. Save the page.

     

    In this case all configuration of sublist (expressions) works.

    0
  • Ardevia Forum

    Original Post by iryna (Imported from Ardevia Forum)

    Concerning site templates:
    All installed apps should be deleted before saving a site as a template and installed again on the restored site.
    It's out of the box SharePoint behavior.

    0
  • Ardevia Forum

    Original Post by Henric (Imported from Ardevia Forum)

    Originally Posted by: iryna

    Concerning site templates:

    All installed apps should be deleted before saving a site as a template and installed again on the restored site.

    It's out of the box SharePoint behavior.

     

    Is it nessecary for Ardevia RichForms to be installed on the site created from the template? There is no need to change any of the forms created by Ardevia RichForms.

    0
  • Ardevia Forum

    Original Post by iryna (Imported from Ardevia Forum)

    Yes, currently it is necessary for Ardevia RichForms to be installed on the site created from the template.
    But you can install a free version even if the customization was done with the pro.

    0
  • Ardevia Forum

    Original Post by Henric (Imported from Ardevia Forum)

    I have created a template subsite (first removed the Ardevia RichFormsapp) and then created a subsite based on that template. Then I installes RichForms on that site but the forms are empty. When I have a look at the page in RichForms it only shows the Rich Forms Editor and name of the list but the whole section is empty.

     

    I should perhaps mention that I have a small Script Editor web part on the page as well (which is working fine in the template site). It just adds a thin line between the QuickLaunch and the form.

    0
  • Ardevia Forum

    Original Post by iryna (Imported from Ardevia Forum)

    Hello
    We tried to reproduce the described issue, everything worked properly.

     

    Can you please check:

     

    1. If the source code of the page looks like the source code of the page from the parent site (the source code can be copied using 'Format text' tab of the ribbon -> 'Edit Source' button)

     

    2. And if there are some errors in console when you open the form (it can be checked with the browser developer tools (F12))

    0

Please sign in to leave a comment.