Skip to main content

Search

Deployment error

Comments

4 comments

  • Taras Lozynskyy

    Jeroen Struik

     

    Try to do the following:
     Check are they really enabled:

     

    Connect-SPOService https://yoursite-admin.sharepoint.com
    Get-SPOSite -Identity https://yoursite.sharepoint.com -Detailed  | FL

     

    There should be a "DenyAddAndCustomizePages" property. If the status is "Disabled", the capabilities are enabled.

     

     

    To enable scripting on a particular site collection immediately, use the following PowerShell command:

     

    Set-SPOSite -Identity https://yoursite.sharepoint.com -DenyAddAndCustomizePages $false

     

    To disable:

    Set-SPOSite -Identity https://yoursite.sharepoint.com -DenyAddAndCustomizePages $true


    Hope this helps.

    0
  • Jeroen Struik

    Thanks. I guess it took some time, later it all worked.

    0
  • Patrick Tognella

    We have the issue, that Cross Site Lookup fields are running into an error. Whats the procedure to set the reference to the correct site?

    0
  • Christof Nussbaumer

    Depends on where problem occures.

     

    For deployments you can correct cross-site lookup source during verification step:

     

    Since you can't change the target list of a lookup field in SharePoint it's not possible to correct that on SharePoint UI.

    You have to update the schema programmatically. https://www.google.com/search?q=change+source+list+sharepoint+lookup+column

    0

Please sign in to leave a comment.